Windows não inicia após CLASSPNP.SYS

Correção de Inicialização

O problema e como identificar

Nos Windows 7 e 8 é muito comum algum problema acontecer e o computador não iniciar mais.

Ao ligar o computador ele começa a carregar o sistema e reinicia. Após isto, ele entra em um modo de Correção de Inicialização, mas isto nem sempre ajuda.

Para identificar este problema, utilizaremos o método de boot seguro.

Para isto, ao iniciar o computador, após a tela inicial da BIOS, pressione (várias vezes) a tecla F8.

Será carregada uma tela mais ou menos assim (depende da versão do Windows)

Opções de Inicialização

Opções de Inicialização

Selecione a opção “Modo Seguro”

Após isto, os arquivos necessários para inicialização começam a ser carregados. Neste passo o Windows carrega arquivos de sistema, drivers, etc…

Agora fique atento ao carregamento do sistema. Se, após carregar o arquivo CLASSPNP.SYS o computador reiniciar novamente, seguimos para o próximo passo.

Windows Reinicia após carregar ClassPNP.SYS

Windows Reinicia após carregar ClassPNP.SYS

Este é o problema que tratamos neste artigo.

Solução

Aqui falo de quatro situações que resolvem este problema, porém existem outras onde este erro não possui solução.

Tente uma a uma das soluções abaixo. Faça a alteração, reinicie e veja se resolveu o problema :

1) Controladora SATA em modo diferente da instalação.

Por alguma desconfiguração de BIOS, o modo de operar do SATA se altera.

Reinicie o computador, entre na BIOS (DEL, F2, F11 ou F12 dependendo do caso)

Procure a configuração de SATA e mude para IDE ou AHCI. (cada placa mãe tem uma BIOS diferente)

Reinicie o computador, caso não dê certo, tente no modo AHCI

2) Desabilitar dispositivos periféricos onboard

Da mesma forma, entre na BIOS e procure por algo como “Advanced Chipset Features”, “Onboard Devices” ou algo assim.

Agora desabilite (mude para a opção Disabled) todos os periféricos que encontrar : Audio, LAN, Ethernet, Modem, 1394. Todos dispositivos secundários.

Os dispositivos básicos deve PERMANECER HABILITADOS (Enabled), como SATA, IDE, VGA, USB, etc…

3) Executar uma verificação de disco.

Carregue o computador com um disco de instalação do Windows (7 ou 8), vá em “Reparar Computador”, NÃO faça uma restauração de “Image Recovery”. Depois selecionar o tipo de teclado US ou ABNT (com Ç), e um OK no nome de usuário. Acesse o “Prompt de Comando”.

Localize qual drive contém seus arquivos, normalmente é o D: ou C:

Para isto, entre (no prompt mesmo) e digite C: [Enter] DIR [enter] e deve conter as pastas WINDOWS, USERS, etc… Se tiverem estas pastas está certo o drive C:, senão repita o procedimento para o D:

Assumindo que seu drive seja o C: execute o comando

chkdsk c: /f /r /x [Enter]

Isto demorará bastante e corrigirá os erros na tabela de alocação de arquivos, procurará setores defeituosos, etc…

4) Substituir o arquivo CLASSPNP.SYS

Copie o arquivo CLASSPNP.SYS de uma máquina “sadia” e coloque no mesmo lugar.

Este arquivo encontra-se em \Windows\System32\Drivers

Conclusão

A falha de não carregamento do Windows após o módulo CLASSPNP.SYS pode ter diversas origens, um destes quatro passos resolvem 50 – 70% (aqui no laboratório foi assim) dos casos.

Se nenhum destes resolveu seu problema e o Windows continua não carregando, provavelmente você precisará instalar seu Sistema novamente.

Abraços e até mais.

Outros artigos relacionados

Consertar erro do Windows Update 80070422 Erro no Windows Update 80070422, não é possível instalar as atualizações. Artigo explicando como resolver este erro.
Backup manual do Emissor de NFe O software gratuito de emissor de Nota Fiscal Eletrônica tem muitas coisas que poderiam ser melhoradas, uma delas é o backup das informações. Se o emi...
Partições GPT – O que é, como utilizar e como rem... As partições GPT são uma realidade em computadores e notebooks com HDs maiores que 2 GB. Porém na hora de formatar este computador a partição GPT tem ...

70 comentários em “Windows não inicia após CLASSPNP.SYS

  1. Boa tarde Marcos.
    Tentei os procedimentos indicados, porém, ao acessar a BIOS, não consigo acessar a configuração de SATA – o cursor só se move entre:
    System Time e System Date

    Alguma outra dica?
    grato
    Maurício

  2. O meu note taça normal. eu desliguei ele normalmente. Pouco depois ligaram ele é não inicia mais. aparece essa tela preta de “recuperação de erro do windons” o windows falhou ao iniciar. Uma alteração recente de hardware ou software pode ter sido a causa(que não foi o caso). Outras opcoes: se a energia foi interrompida durante a inicialização, escolha iniciar o windows normalmente. (não sei dizer se foi isso, eu coloquei pra desligar e sai da frente dele). Tentei mudar essa configuração SATA e não adiantou.

    • Olá Bruno, você pode realmente estar com um problema de hardware nele, ou mesmo o Windows que travou em alguma parte.

      Infelizmente se o SATA não te ajudou eu fico de mãos atadas, pois é difícil saber assim à distância.

      Leve a uma assistência próximo a você.

      Abraço e boa sorte

  3. Cara, isso está acontecendo comigo logo na primeira inicialização ( apos formatar ), computador estava com linux e ligou normal, formatei e ao reiniciar para concluir a instalação ele deu erro “O Computador foi reiniciado de forma inesperada ou encontrou um erro inesperado”…. vc tem idéia do q pode ser? ja formatei de novo e o problema repete

  4. Bom dia!!!

    Parabens pela ótima explicação!!!!! Perdi um dia inteiro tentando resolver e após ler este post resolvi o problema em 10 segundos.
    Fiz a troca de AHCI para Enhanced…. O windows entrou novamente!

    Muito, muito obrigado!

  5. Marcos

    Meu windows está travando exatamente nessa tela de inicialização e no modo de segurança dando esse erro no driver class.
    Quando eu tiro minha placa de vídeo off board ele funciona normalmente.
    Antes disso acontecer eu fui testar um HD no meu computador e quando iniciei ficou meio desconfigurado porque estava com dois HDs e depois eu removi… Em outra tentativa de testar o outro PC removi minha placa de video testei e depois coloquei no lugar de novo e o PC ligou normal e funcionou normal, quando foi de noite me apareceu esse erro e esse problema na inicialização. Não sou técnico nem nada, mas acredito que esse erro se refere a placa de vídeo e acho que corrompeu algum arquivo do windows ou do driver de vídeo. Quando chegar em casa ligarei ele sem a placa, vou remover o driver e depois eu coloco e instalo o driver. tenho 2 anos com o PC e com a placa de vídeo, sim é compatível, sim a fonte é boa, sim testei todos ai de cima e não funcionou, mudando de IDE para AHCI da tela azul e ele reinicia. se caso não funcionar farei um backup e formatarei.
    Mas é isso cara, sem placa ele liga e com placa ele trava… a placa de video ta funcionando, pois o cooler dela liga também quando eu ligo o PC. Obrigado espero que consiga alguma ajuda pra mim. Conheço um pouco de informatica, mas me acho leigo.

  6. Boa noite Marcos,

    Preciso de um help mais detalhado sou bem leiga nesse assunto, meu not é um Acer Aspire 5741- o meu problema tambem é o mesmo caso apertei a f8 e ao carregar ele simplesmente trava CLASSPNP.SYS e pelo que ja pesquisei aqui em outros foruns o seu é o mais indicado e acredito que possa me ajudar, eu tenho que clicar varias vezes na tecla f2 e Del? Isso nao entendi rs…. me ajuda por favor? Preciso terminar um trabalho e chegue em casa me deparei com esse problema, agradeço desde ja e fico no aguardo.

    • Olá Micheli,

      Tem que entrar na BIOS do notebook. Este é um procedimento que PODE resolver. Nem todos os problemas quando ele trava no classpnp são resolvidos desta forma.

      Mas pela minha experiência, resolveu muitos casos.

      Se você não sabe acessar a BIOS peça ajuda a alguem que saiba.

  7. Gentem:

    Tive o mesmo problema do CLASSPNP.SYS num Windows Server 2008 R2, tentei todas as soluçoes propostas e nada, até que um companheiro me falou para fazer um Clear Cmos (jumperzinho na placa mae) … e pasmem! Funcionoou tudo OK. Fica a Dica.
    Abraço e Feliz Natal/Ano Novo 2016

    • Olá Amilcar,

      Pode ser uma boa fazer isto, porém quero deixar um aviso para as outras pessoas do blog, pois quando você zera a BIOS, ela retorna a sua configuração “de fábrica”, e muitos destes problemas do CLASSPNP se dão justamente por isto, pois quando ela “zera”, ela muda para AHCI, e se o Windows foi instalado em IDE dá este erro.

      No seu caso, pode ter acontecido da BIOS estar com algo mau configurado ou corrompido, ou mesmo estar em SATA e quando você resetou a BIOS ela retornou para IDE

      Isto vai depender de cada caso, pois como disse se vc instalou o Windows em IDE e muda para AHCI ela dá erro e o contrário também acontece.

      Mas obrigado pela sua contribuição e pelo tempo dispensado para ajudar os outros.

      Fico muito contente quando mais pessoas se ajudam neste espaço.

      Abraços

  8. Não sei mais o que fazer, ja tentei os 3 primeiros exemplos e continua reiniciando na inicialização do Windows, teria como dar umas luz e explicar um pouco mais detalhadamente como eu coloco o classpnp.sys no pc defeituoso, sendo que ele não liga

    OBS: Já formatei o hd e não funcionou
    OBS 2: ja coloquei outro hd com o Windows XP instalado e também não funcionou, continuou travando na inicialização do Windows

      • Olá Dennis,

        Acredito que você está com outro problema. Deve ser algo de Hardware, pode ser o próprio HD. Porque normalmente quando vc instala o Windows do zero ele tem que instalar e funcionar tudo perfeitamente. Este é até um teste que fazemos aqui, quando tem dúvidas quando ao hardware e quer testá-lo, formatamos e começamos do zero, se não funcionar perfeitamente tem algum problema de hardware. Pode ser HD, Memória, CPU, Placa mãe…

        • Boa noite Marcos, agradeço pela resposta

          Em relação ao hd, tenho quase certeza de que não é o problem, pelo fato de o mesmo hd ja ter sido testado em outro pc e funcionou normalmente, e também outros hd funcionando perfeitamente dar o mesmo erro quando instalado neste pc, o problema deve se na placa mae ou CPU, pois as demais ja foram testas e estao OK… agradeço pela atenção, parabéns pelo blog

  9. Meu note é um compaq cq40, não tem na bios a opção de mudar a controladora sata /ide, no mode seguro ele para na inicialização classpnp.sys ( não reinicia) o que devo fazer? Já troquei de HD, memória, na instalação do windows também trava e para. Help

    • Olá Leonardo,

      Eu procurei na internet sua BIOS e tem sim, dentro de IDE Configuration (Configure SATA as). Mas se você está trocando tudo e continua dando problema não deve ser isso, pois o Windows 7 (e posterior) instala em ambas as situações (AHCI e IDE). Você deve estar com outro problema. Pode ser aquecimento, ponte sul em curto, conectores de memória com problemas, enfim… recomendo que você mande para uma assistência.

      Abraço

  10. Valeu Irmao, salvou meu dia, atualizei a bios de note, depois disso nao subia nem a pau, ja tinha tentado tudo, ai vi a dica sobre alterar a controladora sata e deu certo. obrigado.

  11. Só nao fiz a ultima opção pois não sei como vou passar um arquivo de um pc para o outro sendo que ele nao liga. Nenhuma funcionou. Segue sem solução =\. Acho que o unico modo é formatar este notebook. Se tiverem mais a ser tentado. por favor, me digam.

    • Ah, pode ser que causou um setor defeituoso no HD neste arquivo.

      Tente um DVD ou USB de boot do Windows 7, vá para a reparação de sistema, modo avançado. Depois entre em prompt de comando.

      Acesse o drive D: e veja com o comando DIR se é este o seu drive de Windows, se for dê um comando :
      CHKDSK d: /x /f /r
      Este comando fará uma busca por erros no disco e ainda corrige algumas coisas, mas se for o HD é perigoso ele apagar muitos arquivos “

  12. Tentei de todas as formas nem abre a verificação de disco.
    Tentei colocar o hd eu outro pc para copiar o arquivo CLASSPNP.SYS mais o computador nem liga.

  13. Salvou meu dia este post! Estava o dia inteiro tentando resolver esta situação. Tentei de tudo, gravei uns 3 cds de reparo e 2 pendrives bootaveis em UEFI, até que notei pelo MODO DE SEGURANÇA que o boot parava no CLASSPNP.SYS. Pesquisei no google e este foi o primeiro artigo. Fiz a troca de IDE para AHCI e tá la.. O windows entrou novamente! Muito, muito obrigado!

      • Não intenção de ajudar, eu tenho um servidor com 3 HDs SATA. Desligo a máquina toda a sexta e volta a liga-la na segunda as 06:00hs. Um dia reparei que estava dando erro em um HD. Felizmente não era o HD do Windows/Dados e o de backup, mas sim um HD aonde eu guardava tralhas antigas. Tipo Histórico. Continuei desligando a máquina e religando. Hoje dia 27/08/2015, faltou luz na empresa e como estava ausente, o Nobreack não segurou tanto tempo e o servidor desligou …. Ao voltar tentei ligar o servidor e o boot parava neste arquivo: CLASSPNP.SYS. Comecei a ler o seu post Marcos Carvalho e fiquei curioso … Admito que não fiz as alterações que voce sugeriu, Simplesmente desliguei o servidor e desconectei o HD que estava JÁ DANDO problema. Conclusão: o servidor ligou perfeitamente.

        Digo isso pois no meu caso foi um outro HD sem ser o HD do windows, apesar de estar dando erro no arquivo do windows. Detalhe: O outro HD estava vazio e o Escplorer do windows nem mais o identificava. Apesar disso, dava erro no boot.

        Mas desde já agradeço pois com o seu post ATENTEI para a lembrança do HD com defeito e me ajudou e muito.

        • Olá,

          Obrigado por compartilhar sua experiência. Realmente, pode ver no post que tem uma situação para mudar a forma de leitura do HD, portanto se tiver um HD com problema, desligamento errado, setores defeituosos, ou outras coisas, realmente pode ocorrer a mesma falha.

          Que bom que você resolveu, vou até colocar aqui uma situação de problema de disco.

          Abraço

Deixe uma resposta

O seu endereço de e-mail não será publicado. Campos obrigatórios são marcados com *