Erro Api-ms-win-crt-runtime-l1-1-0.dll está faltando

Como consertar o erro quando seu aplicativo não abre dizendo que falta o arquivo Api-ms-win-crt-runtime-l1-1-0.dll
Autor: Marcos Carvalho 8 de março de 2017
Erro Skype api-ms-win-crt-runtime-l1-1-0.dll

O arquivo api-ms-win-ctr-runtime-l1-1-0.dll é parte de uma biblioteca essencial para alguns programas do Windows. Esta biblioteca é parte da Universal C Runtime (CRT) no Windows, ou simplesmente parte de um componente C++.

Quando outros desenvolvedores fazem seus programas, estes dependem de bibliotecas externas (quase sempre de terceiros) para que a aplicação seja executada.

É um pré-requisito de muitos softwares. Em específico a api-ms-win-crt-runtime-l1-1-0.dll é utilizado por muitos programas, entre eles o SkypePokemin Alpha SapphireSmartFTPAutoCadKontaktSageLabView, Photoshop, entre outros… A lista é imensa, uma vez que C++ está presente em muitas aplicações.

Resolvendo o erro do api-ms-ctr-runtime

O procedimento é extremamente simples.

Verifique as atualizações

Primeiro de tudo, verifique se seu computador possui Atualizações a serem instaladas, pois as vezes na própria atualização o problema é resolvido.

Windows 7

Clique em Iniciar -> Painel de Controle -> Windows Update -> Procurar Atualizações / Instalar Atualizações

Windows 8 ou 10

Vá na Busca -> Atualizações -> Encontre o “Verificar atualizações”

Baixar manualmente o pacote C++ para reinstalar

Caso não tenha resolvido com as atualizações, você pode baixar diretamente do @BlogDaInformatica, que tem o link para o Site oficial da Microsoft, o pacote relativo ao seu Sistema Operacional. Veja abaixo :

Download para todas as versões do Windows.

Windows 10 Universal C Runtime para Windows 10, 8.1, 8, 7 ou vista

Baixe o pacote para todas as versões do Windows
(Incluído em 26/05/2018)

Ou os pacotes antigos disponibilizados pela Microsoft.

Todas as versões compatíveis com o Windows 8.1 x86Download Baixe o pacote agora
Todas as versões compatíveis com o Windows 8.1 x64Download Baixe o pacote agora
Todas as versões compatíveis com o Windows Server 2012 R2 x64Download Baixe o pacote agora
Todas as versões compatíveis com o Windows 8 x86Download Baixe o pacote agora
Todas as versões compatíveis com o Windows 8 x64Download Baixe o pacote agora
Todas asversões compatíveis com o Windows Server 2012 x64Download Baixe o pacote agora
Todas as versões compatíveis do Windows 7 x86Download Baixe o pacote agora
Todas as versões compatíveis do Windows 7 x64Download Baixe o pacote agora
Todas as versões compatíveis do Windows Server 2008 R2 x64Download Baixe o pacote agora
Todas as versões baseadas em x86 do Windows Vista com suporteDownload Baixe o pacote agora
Todas as versões baseadas em x64 do Windows Vista com suporteDownload Baixe o pacote agora
Todas as versões baseadas em x86 do Windows Server 2008 com suporteDownload Baixe o pacote agora
Todas as versões baseadas em x64 do Windows Server 2008 com suporteDownload Baixe o pacote agora

Importante: Para instalar essa atualização, você deve a atualização para o Windows RT 8.1, 8.1 para Windows e Windows Server 2012 R2 (2919355) instalado no Windows Server 2012 R2 ou no Windows 8.1. Ou, instale o Service Pack 1 para o Windows 7 ou Windows Server 2008 R2. Ou então, o Service Pack 2 para Windows Vista e Windows Server 2008.

Após a instalação, tente novamente abrir o aplicativo que não conseguia e ele abrirá.

LEIA  Não é possível iniciar o Microsoft Outlook

Um abraço a todos.

 

WalmartBR

21 comentários em “Erro Api-ms-win-crt-runtime-l1-1-0.dll está faltando

  1. Para mim deu certo…
    É importante ler com atenção e seguir passa a passo que vai dá certo.
    Não estava conseguindo instalar o PHOTOSHOP 2018, A Dll, estava dando erro.
    Mas seguir passo a passo e deu certo.

  2. Olá! Atualizei meu Adobe Lightroom para a versão 6.13 e começou com esse erro.
    Fiz o procedimento, conforme escrito, e não obtive êxito. Aparece uma mensagem de “A atualização não pode ser aplicada ao seu computador”

    Se puder me ajudar, agradeço!

    Mike Castro – Maringá, pr

  3. Ocorre esse erro quando tento executar o QuantumGis…tentei corrigir esse erro pelos 2 metodos, porem sem sucesso. Meu windows é o 7, e aparece a mensagem Instalador Autônomo do Windows Update e A atualização não pode ser aplicada ao seu computador.

    Se alguem tiver alguma solução, agradeço.

  4. Ola amigo, nao esta resolvendo tenho todos programs CC++ e os recomendados Windows 99% atulizado a unica atulizaçao que nao fiz foi a de por idiomas extras, ja baixei esse seu programa e nada…Se poderia me ajudar?

  5. Ocorre esse erro quando tento executar o QuantumGis…tentei corrigir esse erro pelos 2 metodos, porem sem sucesso. Meu windows é o 8.1 pro, e aparece a mensagem Instalador Autônomo do Windows Update e A atualização não pode ser aplicada ao seu computador.

    Se alguem tiver alguma solução, agradeço.

  6. Muito bom, mas infelizmente não consigo ainda utilizar nada ligado ao Visual C++, o meu da esse erro:
    —————————
    Instalador Autônomo do Windows Update
    —————————
    A atualização não pode ser aplicada ao seu computador.

    —————————
    OK
    —————————

    E quando tento colocar para procurar atualizações, só fala para reiniciar, fiz isso 7 vezes e ainda não procura nada, só fala isso, o que fazer sabe me dizer?

    • Olá amigo! não sei se é o caso, mas observe que os requisitos de instalação para essa atualização é ter o Windows 7 Service Pack 1. Certifique-se de que essa atualização importante já foi realizada em seu sistema antes de executar a atualização do pacote KB2999226. Grande abraço!!

Deixe uma resposta

O seu endereço de e-mail não será publicado. Campos obrigatórios são marcados com *

This site uses Akismet to reduce spam. Learn how your comment data is processed.